Network Manager - get_secrets_cb(): Couldn't get connection secrets

root's picture

Well, I got this error today, in /var/log/syslog, when I wanted to connect to wireless network:

Mar  2 08:57:28 localhost NetworkManager: <info>  Activation (wlan0) starting connection 'MY LEET WLAN'
Mar  2 08:57:28 localhost NetworkManager: <info>  (wlan0): device state change: 3 -> 4
Mar  2 08:57:28 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Mar  2 08:57:28 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Mar  2 08:57:28 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Mar  2 08:57:28 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Mar  2 08:57:28 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Mar  2 08:57:28 localhost NetworkManager: <info>  (wlan0): device state change: 4 -> 5
Mar  2 08:57:28 localhost NetworkManager: <info>  Activation (wlan0/wireless): access point 'MY LEET WLAN' has security, but secrets are required.
Mar  2 08:57:28 localhost NetworkManager: <info>  (wlan0): device state change: 5 -> 6
Mar  2 08:57:28 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
[color=red]Mar  2 08:57:28 localhost NetworkManager: <WARN>  get_secrets_cb(): Couldn't get connection secrets: Rejected send message, 6 matched rules; type="method_call", sender=":1.40097" (uid=0 pid=4874 comm="/usr/sbin/NetworkManager ") interface="org.freedesktop.NetworkManagerSettings.Connection.Secrets" member="GetSecrets" error name="(unset)" requested_reply=0 destination="org.freedesktop.NetworkManagerUserSettings" (uid=1000 pid=10633 comm="nm-applet --sm-disable ")).[/color]
Mar  2 08:57:28 localhost NetworkManager: <info>  (wlan0): device state change: 6 -> 9
Mar  2 08:57:28 localhost NetworkManager: <info>  Activation (wlan0) failed for access point (LEETWLAN)
Mar  2 08:57:28 localhost NetworkManager: <info>  Marking connection 'MY LEET WLAN' invalid.
Mar  2 08:57:28 localhost NetworkManager: <info>  Activation (wlan0) failed.
Mar  2 08:57:28 localhost NetworkManager: <info>  (wlan0): device state change: 9 -> 3
Mar  2 08:57:28 localhost NetworkManager: <info>  (wlan0): deactivating device (reason: 0).

I was about to reboot until I found this bug. The bug was not my case but some of the responses gave me the solution. By the way, I have Debian but it should be ok for other distributions too, apart from maybe stop/start scripts location. So, this is what I did:

1. Stop Graphical interface (Gnome/KDE/etc), network-manager, dbus:

root@florian:/root # /etc/init.d/network-manager stop
 * Stopping network connection manager NetworkManager                                [ ok ]
root@florian:/root # /etc/init.d/dbus stop
 * Stopping System Tools Backends system-tools-backends                              [ ok ] 
 * Stopping network connection manager NetworkManager                                [ ok ] 
 * Stopping bluetooth                                                                [ ok ] 
 * Stopping Hardware abstraction layer hald                                          [ ok ] 
 * Stopping Avahi mDNS/DNS-SD Daemon avahi-daemon                                    [ ok ] 
 * Stopping system message bus dbus                                                  [ ok ]

2. Start everything up again:

root@florian:/root # /etc/init.d/dbus start
 * Starting system message bus dbus                                                  [ ok ] 
 * Starting Avahi mDNS/DNS-SD Daemon avahi-daemon                                    [ ok ] 
 * Starting Hardware abstraction layer hald                                          [ ok ] 
 * Starting bluetooth                                                                [ ok ] 
 * Starting network connection manager NetworkManager                                [ ok ] 
 * Starting System Tools Backends system-tools-backends                              [ ok ] 
root@florian:/root # /etc/init.d/network-manager start
 * Starting network connection manager NetworkManager                                [ ok ]

3. Problem solved:

Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) starting connection 'MY LEET WLAN'
Mar  2 09:11:04 localhost NetworkManager: <info>  (wlan0): device state change: 3 -> 4
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Mar  2 09:11:04 localhost NetworkManager: <info>  (wlan0): device state change: 4 -> 5
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0/wireless): access point 'MY LEET WLAN' has security, but secrets are required.
Mar  2 09:11:04 localhost NetworkManager: <info>  (wlan0): device state change: 5 -> 6
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Mar  2 09:11:04 localhost NetworkManager: <info>  (wlan0): supplicant connection state:  completed -> disconnected
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Mar  2 09:11:04 localhost NetworkManager: <info>  (wlan0): device state change: 6 -> 4
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Mar  2 09:11:04 localhost NetworkManager: <info>  (wlan0): device state change: 4 -> 5
[color=green]Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0/wireless): connection 'MY LEET WLAN' has security, and secrets exist.  No new secrets needed.[/color]
Mar  2 09:11:04 localhost NetworkManager: <info>  Config: added 'ssid' value 'LEETWLAN'
Mar  2 09:11:04 localhost NetworkManager: <info>  Config: added 'scan_ssid' value '1'
Mar  2 09:11:04 localhost NetworkManager: <info>  Config: added 'key_mgmt' value 'WPA-EAP'
Mar  2 09:11:04 localhost NetworkManager: <info>  Config: added 'password' value '<omitted>'
Mar  2 09:11:04 localhost NetworkManager: <info>  Config: added 'eap' value 'LEAP'
Mar  2 09:11:04 localhost NetworkManager: <info>  Config: added 'fragment_size' value '1300'
Mar  2 09:11:04 localhost NetworkManager: <info>  Config: added 'identity' value 'myusername'
Mar  2 09:11:04 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Mar  2 09:11:04 localhost NetworkManager: <info>  Config: set interface ap_scan to 1
Mar  2 09:11:04 localhost NetworkManager: <info>  (wlan0): supplicant connection state:  disconnected -> scanning

Thou shalt not steal!

If you want to use this information on your own website, please remember: by doing copy/paste entirely it is always stealing and you should be ashamed of yourself! Have at least the decency to create your own text and comments and run the commands on your own servers and provide your output, not what I did!

Or at least link back to this website.

Recent content